summary refs log tree commit diff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-12-04 20:10:23 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-12-04 22:06:23 +0100
commitd29f14aca2d3dcb1bdbd214d33924ec4cb694793 (patch)
tree9b3e706e4ce9457f6cd01cf0fd5d57b6282458cf /gnu/packages/maven-parent-pom.scm
parent98d2abe5230d53fc625d3654e521b5be0f0e1c51 (diff)
downloadguix-d29f14aca2d3dcb1bdbd214d33924ec4cb694793.tar.gz
gnu: java-sonatype-oss-parent-pom-9: Remove references to %build-inputs.
* gnu/packages/maven-parent-pom.scm (java-sonatype-oss-parent-pom-9)
[arguments]: Use a gexp to remove references to %build-inputs.
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index 84af3a1c53..27f0926348 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2020, 2021 Julien Lepiller <julien@lepiller.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,6 +20,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module (guix build-system ant)
@@ -321,14 +322,15 @@ other projects as their parent pom.")
                  (base32
                   "0yl2hbwz2kn1hll1i00ddzn8f89bfdcjwdifz0pj2j15k1gjch7v"))))
       (arguments
-       `(#:tests? #f
+       (list
+         #:tests? #f
          #:phases
-         (modify-phases %standard-phases
-           (delete 'unpack)
-           (delete 'configure)
-           (delete 'build)
-           (replace 'install
-             (install-pom-file (assoc-ref %build-inputs "source")))))))))
+         #~(modify-phases %standard-phases
+             (delete 'unpack)
+             (delete 'configure)
+             (delete 'build)
+             (replace 'install
+               (install-pom-file #$(package-source this-package)))))))))
 
 (define* (make-plexus-parent-pom version hash #:optional parent)
   (hidden-package