summary refs log tree commit diff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 14:26:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:10:54 +0200
commitbef4d92050928cee6eafd2bde580b27bf16056da (patch)
tree31480774eddd99aedd5a009572b2f9250a29ed74 /gnu/packages/maven-parent-pom.scm
parentfff4fcc4e22f11788dfaf103141ff6cffbf788dc (diff)
downloadguix-bef4d92050928cee6eafd2bde580b27bf16056da.tar.gz
gnu: Add apache-parent-pom-13.
* gnu/packages/maven-parent-pom.scm: New file.
* gnu/local.mk: Add maven-parent-pom.scm.
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
new file mode 100644
index 0000000000..b1bc44696b
--- /dev/null
+++ b/gnu/packages/maven-parent-pom.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages maven-parent-pom)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system ant)
+  #:use-module (gnu packages java))
+
+(define (make-apache-parent-pom version hash)
+  (hidden-package
+    (package
+      (name "apache-parent-pom")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/apache/maven-apache-parent")
+                       (commit (string-append "apache-" version))))
+                (file-name (git-file-name name version))
+                (sha256 (base32 hash))))
+      (build-system ant-build-system)
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (delete 'build)
+           (replace 'install
+             (install-pom-file "pom.xml")))))
+      (home-page "https://apache.org/")
+      (synopsis "Apache parent pom")
+      (description "This package contains the Apache parent POM.")
+      (license license:asl2.0))))
+
+(define-public apache-parent-pom-13
+  (make-apache-parent-pom
+    "13" "1cfxaz1jy8fbn06sb648qpiq23swpbj3kb5ya7f9g9jmya5fy09z"))