summary refs log tree commit diff
path: root/gnu/packages/maven.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-26 13:51:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-06-26 13:51:26 +0200
commita167873c67a17df8175f896750de2d905d0fae04 (patch)
treee84bd2845b5456ef67e7337f54bdb3cc2e5b7512 /gnu/packages/maven.scm
parent7c3bea7e6299e1026c7964c83986a6b6c220879a (diff)
parent7c7323e432620a42f896056f076020a748c1fd6d (diff)
downloadguix-a167873c67a17df8175f896750de2d905d0fae04.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/maven.scm')
-rw-r--r--gnu/packages/maven.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 0feb01f040..f63fcee6b2 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -23,6 +23,7 @@
   #:use-module (guix utils)
   #:use-module (guix build-system ant)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages java)
   #:use-module (gnu packages web)
@@ -1079,6 +1080,18 @@ generally generated from plugin sources using maven-plugin-plugin.")))
              (mkdir-p "build/classes/")
              (copy-recursively "src/main/resources" "build/classes")
              #t))
+         (add-after 'copy-resources 'fill-properties
+           (lambda _
+             ;; This file controls the output of some mvn subcommands, such as
+             ;; mvn -version.
+             (substitute* "build/classes/org/apache/maven/messages/build.properties"
+               (("\\$\\{buildNumber\\}") "guix_build")
+               (("\\$\\{timestamp\\}") "0")
+               (("\\$\\{project.version\\}") ,(package-version maven-artifact))
+               (("\\$\\{distributionId\\}") "apache-maven")
+               (("\\$\\{distributionShortName\\}") "Maven")
+               (("\\$\\{distributionName\\}") "Apache Maven"))
+             #t))
          (add-before 'build 'generate-sisu-named
            (lambda _
              (mkdir-p "build/classes/META-INF/sisu")
@@ -1502,6 +1515,9 @@ layer for plugins that need to keep Maven2 compatibility.")))
        ("java-slf4j-api" ,java-slf4j-api)
        ;; TODO: replace with maven-slf4j-provider
        ("java-slf4j-simple" ,java-slf4j-simple)))
+    (propagated-inputs
+     `(("coreutils" ,coreutils)
+       ("which" ,which)))
     (description "Apache Maven is a software project management and comprehension
 tool.  Based on the concept of a project object model: builds, dependency
 management, documentation creation, site publication, and distribution