summary refs log tree commit diff
path: root/gnu/packages/maven.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 15:49:25 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:16:18 +0200
commit7a85b602ca7102a6141c55c0936fe41757f57a41 (patch)
treefdf341d6f2e9e53eb25681d12a7b622fc671e246 /gnu/packages/maven.scm
parent5d1a24dd894d46e5647723977a9701a74b3c060d (diff)
downloadguix-7a85b602ca7102a6141c55c0936fe41757f57a41.tar.gz
gnu: Add java-eclipse-aether-test-util.
* gnu/packages/maven.scm (java-eclipse-aether-test-util): New variable.
Diffstat (limited to 'gnu/packages/maven.scm')
-rw-r--r--gnu/packages/maven.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index bfbe21c948..5e6d7aeaed 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -538,6 +538,24 @@ ease usage of the repository system.")))
     (description "This package contains the service provider interface (SPI)
 for repository system implementations and repository connectors.")))
 
+(define-public java-eclipse-aether-test-util
+  (package
+    (inherit java-eclipse-aether-api)
+    (name "java-eclipse-aether-test-util")
+    (arguments
+     `(#:jar-name "aether-test-util.jar"
+       #:source-dir "aether-test-util/src/main/java"
+       #:test-dir "aether-test-util/src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'install (install-from-pom "aether-util/pom.xml")))))
+    (propagated-inputs
+     `(("java-eclipse-aether-api" ,java-eclipse-aether-api)
+       ("java-eclipse-aether-spi" ,java-eclipse-aether-spi)))
+    (synopsis "Utility classes for testing the maven repository system")
+    (description "This package contains a collection of utility classes to
+ease testing of the repository system.")))
+
 (define-public maven-shared-utils
   (package
     (name "maven-shared-utils")