summary refs log tree commit diff
path: root/gnu/packages/maven.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-17 16:31:01 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-06-16 13:17:56 +0200
commita59d5f3542cc2c0b327f6c2bb84ba8a82be04c57 (patch)
tree071db2a2ff2202ba7100fa5a7a2fe11275425a8c /gnu/packages/maven.scm
parent7a42f0586910418c72d4df3abecc5ded6b3aa309 (diff)
downloadguix-a59d5f3542cc2c0b327f6c2bb84ba8a82be04c57.tar.gz
gnu: Add maven-plugin-annotations.
* gnu/packages/maven.scm (maven-plugin-annotations): New variable.
Diffstat (limited to 'gnu/packages/maven.scm')
-rw-r--r--gnu/packages/maven.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 59cee90785..09fab71108 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -230,6 +230,30 @@ plexus-utils in Maven.  It is not a 100% API compatible replacement but a
 replacement with improvements.")
     (license license:asl2.0)))
 
+(define-public maven-plugin-annotations
+  (package
+    (name "maven-plugin-annotations")
+    (version "3.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.apache.org/dist/maven/"
+                                  "plugin-tools/maven-plugin-tools-" version
+                                  "-source-release.zip"))
+              (sha256 (base32 "1ryqhs62j5pas93brhf5dsnvp99hxbvssf681yj5rk3r9h24hqm2"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "maven-plugin-annotations.jar"
+       #:source-dir "maven-plugin-annotations/src/main/java"
+       #:tests? #f))
+    (inputs
+     `(("maven-artifact" ,maven-artifact)))
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (home-page "https://maven.apache.org/plugin-tools/maven-plugin-annotations/")
+    (synopsis "Java 5 annotations to use in Mojos")
+    (description "This package contains Java 5 annotations for use in Mojos.")
+    (license license:asl2.0)))
+
 (define-public maven-artifact
   (package
     (name "maven-artifact")