summary refs log tree commit diff
path: root/gnu/packages/mc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-16 14:36:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-16 14:36:09 +0100
commit889b4af7d89a8ce0f05e210b6bd2212f787659a4 (patch)
tree5115d22a3dec05118289d606ecdeade592209b15 /gnu/packages/mc.scm
parent10db64e1b0508100395ff67f19e394f9b45912fa (diff)
downloadguix-889b4af7d89a8ce0f05e210b6bd2212f787659a4.tar.gz
gnu: mc: Update to 4.8.20.
* gnu/packages/mc.scm (mc): Update to 4.8.20.
[arguments]: Rename ‘fix-absolutism’ to (hopefully) more accurate
‘patch-FHS-file-names’.  Patch more.  Fix new VFS test.
Diffstat (limited to 'gnu/packages/mc.scm')
-rw-r--r--gnu/packages/mc.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 73e0503935..2e13c3201f 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,7 +37,7 @@
 (define-public mc
   (package
     (name "mc")
-    (version "4.8.16")
+    (version "4.8.20")
     (source
      (origin
       (method url-fetch)
@@ -44,7 +45,7 @@
                           version ".tar.xz"))
       (sha256
        (base32
-        "083h5gwc0nny9b557way5dsmj71g2bzkiai4bn30y5nkjwqbxg5v"))))
+        "072h7n9b3j79fqn48xaw0xhlcjavpsmfpz6nyh20lhmfz3sffzh1"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("perl" ,perl)))
@@ -59,14 +60,24 @@
        '("--with-screen=ncurses" "--enable-aspell")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'patch-source-shebangs 'fix-absolutism
+         (add-after 'patch-source-shebangs 'patch-FHS-file-names
            (lambda _
-             ;; Modify files that contain absolute file names.
+             ;; Patch files to refer to executables in the store.
              (substitute* "misc/mcedit.menu.in"
                (("#! /bin/sh") (string-append "#!" (which "sh")))
                (("/bin/bash") (which "bash")))
              (substitute* "misc/ext.d/misc.sh.in"
                (("/bin/cat") "cat"))
+             (substitute* "tests/src/vfs/extfs/helpers-list/Makefile.in"
+               (("/bin/sh") (which "sh")))
+             #t))
+         (add-before 'check 'fix-tests
+           (lambda _
+             ;; Don't expect a UID or GID of ‘0’ in the build environment.
+             (with-directory-excursion "tests/src/vfs/extfs/helpers-list/data"
+               (substitute* (list "rpm.custom.output"
+                                  "rpm.glib.output")
+                 (("      0        0") "<<uid>>  <<gid>>")))
              #t)))))
     (home-page "https://www.midnight-commander.org")
     (synopsis "Graphical file manager")