summary refs log tree commit diff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-31 22:31:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-31 22:32:05 +0100
commitad6903b15632f940ea59ddc3726c53e9555b73ca (patch)
treea0f8853ea8eab0e19c797083b791aff76022f231 /gnu/packages/mes.scm
parentfb5514d3db19b5b405ea75cbe8fbf72d79baea1d (diff)
downloadguix-ad6903b15632f940ea59ddc3726c53e9555b73ca.tar.gz
gnu: nyacc: Update to 1.08.1.
* gnu/packages/mes.scm (nyacc): Update to 1.08.1.
[arguments]: Remove.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 4487b1b6eb..9ec506a1ed 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -98,29 +98,20 @@ extensive examples, including parsers for the Javascript and C99 languages.")
 (define-public nyacc
   (package
     (inherit nyacc-0.99)
-    (version "1.07.4")
+    (version "1.08.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://savannah/nyacc/nyacc-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1kr3b88sx0g9zy52algxqpvnkjm76qdyld7pasbbajkph2zhcj92"))
+                "1vrz3pnlr3njwk6ksz85slcwawi8ngiqbw94wd9x3mgv85vsfmys"))
               (modules '((guix build utils)))
               (snippet
                '(substitute* "configure"
                   (("GUILE_GLOBAL_SITE=\\$prefix.*")
                    "GUILE_GLOBAL_SITE=\
 $prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n")))))
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         ;; See https://savannah.nongnu.org/bugs/index.php?60474
-         (add-after 'unpack 'fix-60474
-           (lambda _
-             (substitute* "module/nyacc/lang/c99/parser.scm"
-               (("\\(memq \\(car stmt\\) '\\(include include-next\\)\\)")
-                "(memq (car stmt) '(include include-next define))")))))))
     (inputs (list guile-3.0))
     (propagated-inputs (list guile-bytestructures))
     (description