summary refs log tree commit diff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-12 12:22:18 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-12 12:25:08 +0200
commit81a4ca08f7716c730c75ebb2911cf0f5f57dfd3c (patch)
tree5c6a2178c329e2ca58027aa6ef80d700327997f1 /gnu/packages/mes.scm
parent99b73d0f0ce9fdb397fdf211839d73f98e3ddec2 (diff)
downloadguix-81a4ca08f7716c730c75ebb2911cf0f5f57dfd3c.tar.gz
gnu: mescc-tools: Use 'git-fetch'.
* gnu/packages/mes.scm (mescc-tools-0.5.2)[source]: Use 'git-fetch'.
(mescc-tools)[source]: Likewise.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 1b5bb331f5..3174c0c115 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -159,16 +159,16 @@ Guile.")
         (version "0.5.2"))
     (package
       (name "mescc-tools")
-      (version (string-append version "-" revision "." (string-take commit 7)))
+      (version (git-version version revision commit))
       (source (origin
-                (method url-fetch)
-                (uri (string-append
-                      "https://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
-                      name "-" commit
-                      ".tar.gz"))
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.savannah.nongnu.org/r/mescc-tools.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1h6j57wyf91i42b26f8msbv6451cw3nm4nmpl1fckp9c7vi8mwkh"))))
+                  "1nc6rnax66vmhqsjg0kgx23pihdcxmww6v325ywf59vsq1jqjvff"))))
       (build-system gnu-build-system)
       (supported-systems '("i686-linux" "x86_64-linux"))
       (arguments
@@ -191,15 +191,14 @@ get_machine.")
     (name "mescc-tools")
     (version "0.6.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
-                    name "-Release_" version
-                    ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.savannah.nongnu.org/r/mescc-tools.git")
+                    (commit (string-append "Release_" version))))
+              (file-name (string-append "mescc-tools-" version "-checkout"))
               (sha256
                (base32
-                "06jpvq6xfjzn2al6b4rdwd3zv3h4cvilc4n9gqcnjr9cr6wjpw2n"))))
+                "1cgxcdza6ws725x84i31la7jxmlk5a3nsij5shz1zljg0i36kj99"))))
     (arguments
      (substitute-keyword-arguments (package-arguments mescc-tools-0.5.2)
        ((#:make-flags _)