summary refs log tree commit diff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-10-05 13:55:59 +0400
committerAndrew Tropin <andrew@trop.in>2023-10-05 14:16:38 +0400
commit9e963c9d7593c4690e73252c361be36642d6cabf (patch)
tree92c4526efcf45821a1caf933dac10aea14c22255 /gnu/packages/messaging.scm
parent276b9287c13cf996e78323f00ff83f49438a2485 (diff)
downloadguix-9e963c9d7593c4690e73252c361be36642d6cabf.tar.gz
gnu: tdlib: Update to 1.8.16-0.4d1d22d.
* gnu/packages/messaging.scm (tdlib): Update to 1.8.16-0.4d1d22d.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm66
1 files changed, 34 insertions, 32 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7bea3fac91..73f8e9eb6a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2636,41 +2636,43 @@ replacement.")
     (license license:gpl2+)))
 
 (define-public tdlib
-  (package
-    (name "tdlib")
-    (version "1.8.10")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/tdlib/td")
-             (commit "ef4c3902fe082b83192d578af7a0bb956a917fed")))
-       (sha256
-        (base32 "1pi53v8qjl0lzann99pv90i4qx2lbjz10rvnwzkbqbn932y3j3gg"))
-       (file-name (git-file-name name version))))
-    (build-system cmake-build-system)
-    (arguments
-     (list
-      #:build-type "Release"
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-after 'unpack 'remove-failing-tests
-            (lambda _
-              (substitute* "test/CMakeLists.txt"
-                ;; The test cases are compiled into a distinct binary
-                ;; which uses mtproto.cpp to attempt to connect to
-                ;; a remote server. Removing this file from the sources
-                ;; list disables those specific test cases.
-                (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") "")))))))
-    (native-inputs
-     (list gperf openssl zlib php doxygen))
-    (synopsis "Cross-platform library for building Telegram clients")
-    (description "Tdlib is a cross-platform library for creating custom
+  (let ((commit "4d1d22d6f477d61f6ff2b8f6e49de1847092c5b4")
+        (revision "0"))
+    (package
+      (name "tdlib")
+      (version (git-version "1.8.16" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tdlib/td")
+               (commit commit)))
+         (sha256
+          (base32 "0nv921k795kq0l993rxzd5pm5v3l3mnwbaxb7d7d0m0506l4w9fk"))
+         (file-name (git-file-name name version))))
+      (build-system cmake-build-system)
+      (arguments
+       (list
+        #:build-type "Release"
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'remove-failing-tests
+              (lambda _
+                (substitute* "test/CMakeLists.txt"
+                  ;; The test cases are compiled into a distinct binary
+                  ;; which uses mtproto.cpp to attempt to connect to
+                  ;; a remote server. Removing this file from the sources
+                  ;; list disables those specific test cases.
+                  (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") "")))))))
+      (native-inputs
+       (list gperf openssl zlib php doxygen))
+      (synopsis "Cross-platform library for building Telegram clients")
+      (description "Tdlib is a cross-platform library for creating custom
 Telegram clients following the official Telegram API.  It can be easily used
 from almost any programming language with a C-FFI and features first-class
 support for high performance Telegram Bot creation.")
-    (home-page "https://core.telegram.org/tdlib")
-    (license license:boost1.0)))
+      (home-page "https://core.telegram.org/tdlib")
+      (license license:boost1.0))))
 
 (define-public purple-mm-sms
   (package