summary refs log tree commit diff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-18 09:37:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-18 09:58:56 +0200
commit9840b8faafad6aee496e0cc8abe948bde2612020 (patch)
tree3bc776f265c8fe1ab72615557265a6eace9cfb4f /gnu/packages/messaging.scm
parent8b5bf30804785fc34e9517a2941b5b1c4f4e339b (diff)
downloadguix-9840b8faafad6aee496e0cc8abe948bde2612020.tar.gz
gnu: c-toxcore: Update to 0.1.9.
* gnu/packages/messaging.scm (c-toxcore): Update to 0.1.9.
[build-system]: Switch to cmake-build-system.
[native-inputs]: Remove autoconf, automake, libtool, and check.
[inputs]: Rename to...
[propagated-inputs]: ...this.
[arguments]: Remove field.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm30
1 files changed, 9 insertions, 21 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 827e9edee9..eb9e869152 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -670,7 +670,7 @@ protocols.")
 (define-public c-toxcore
   (package
     (name "c-toxcore")
-    (version "0.1.1")
+    (version "0.1.9")
     (source
      (origin
        (method url-fetch)
@@ -679,32 +679,20 @@ protocols.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0dybpz44pi0zm8djppjna0r8yh5wvl3l885dv2f1wp5366bk59n3"))))
-    (build-system gnu-build-system)
+         "1y30xc1dzq9knww274d4y0m8gridcf5j851rxdri8j2s64p3qqgk"))))
+    (build-system cmake-build-system)
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("check" ,check)
-       ("pkg-config" ,pkg-config)))
-    (inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs
      `(("libsodium" ,libsodium)
        ("opus" ,opus)
        ("libvpx" ,libvpx)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'autoconf
-           ;; The tarball source is not bootstrapped.
-           (lambda _
-             (zero? (system* "autoreconf" "-vfi")))))
-       #:tests? #f)) ; FIXME: Testsuite fails, needs internet connection.
+    (home-page "https://tox.chat")
     (synopsis "Library for the Tox encrypted messenger protocol")
     (description
-     "Official fork of the C library implementation of the Tox
-encrypted messenger protocol.")
-    (license license:gpl3+)
-    (home-page "https://tox.chat")))
+     "Official fork of the C library implementation of the Tox encrypted
+messenger protocol.")
+    (license license:gpl3+)))
 
 (define-public utox
   (package