summary refs log tree commit diff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-07 15:52:39 -0500
committerLeo Famulari <leo@famulari.name>2021-03-25 19:19:42 -0400
commita801c7379a534a2896a03a1a6f8b47eb92691b00 (patch)
tree777908afa9d55f8922fe618fdb7fa29383219732 /gnu/packages/messaging.scm
parent0d8cea4f247272a36c307276253f014f271f1b56 (diff)
downloadguix-a801c7379a534a2896a03a1a6f8b47eb92691b00.tar.gz
gnu: Remove QT 4.
For more information, see:

https://lists.gnu.org/archive/html/guix-devel/2016-02/msg00596.html
https://bugs.gnu.org/45704

* gnu/packages/qt.scm (qt-4, python2-pyqt-4): Remove variables.
* gnu/packages/engineering.scm (qucs, qucs-s): Remove variables.
* gnu/packages/messaging.scm (pybitmessage): Remove variable.
* gnu/packages/password-utils.scm (keepassx): Remove variable.
* gnu/packages/pdf.scm (poppler-qt4): Remove variable.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm93
1 files changed, 0 insertions, 93 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a967ac31c2..5c55e08fb2 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1616,99 +1616,6 @@ guidelines.  It provides an easy to use application that allows you to
 connect with friends and family without anyone else listening in.")
     (license license:gpl3+)))
 
-(define-public pybitmessage
-  (package
-    (name "pybitmessage")
-    (version "0.6.3.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/Bitmessage/PyBitmessage")
-             (commit version)))
-       (file-name (string-append name "-" version "-checkout"))
-       (sha256
-        (base32
-         "1lmhbpwsqh1v93krlqqhafw2pc3y0qp8zby186yllbph6s8kdp35"))))
-    (propagated-inputs
-     ;; TODO:
-     ;; Package "pyopencl", required in addition to numpy for OpenCL support.
-     ;; Package "gst123", required in addition to alsa-utils and
-     ;; mpg123 for sound support.
-     `(("python2-msgpack" ,python2-msgpack)
-       ("python2-pythondialog" ,python2-pythondialog)
-       ("python2-pyqt-4" ,python2-pyqt-4)
-       ("python2-sip" ,python2-sip)
-       ("python2-pysqlite" ,python2-pysqlite)
-       ("python2-pyopenssl" ,python2-pyopenssl)))
-    (native-inputs
-     `(("openssl" ,openssl)))
-    (build-system python-build-system)
-    (arguments
-     `(#:modules ((guix build python-build-system)
-                  (guix build utils))
-       #:tests? #f ;no test target
-       #:python ,python-2
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-unmatched-python-shebangs
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "src/bitmessagemain.py"
-               (("#!/usr/bin/env python2.7")
-                (string-append "#!" (which "python"))))
-             (substitute* "src/bitmessagecli.py"
-               (("#!/usr/bin/env python2.7.x")
-                (string-append "#!" (which "python"))))
-             #t))
-         (add-after 'unpack 'fix-depends
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "src/depends.py"
-               (("libcrypto.so")
-                (string-append (assoc-ref inputs "openssl")
-                               "/lib/libcrypto.so")))
-             #t))
-         (add-after 'unpack 'fix-local-files-in-paths
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "src/proofofwork.py"
-               (("bitmsghash.so")
-                (string-append (assoc-ref outputs "out")
-                               "/lib/bitmsghash.so")))
-             #t))
-         (add-after 'unpack 'fix-pyelliptic
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "src/pyelliptic/openssl.py"
-               (("libcrypto.so")
-                (string-append (assoc-ref inputs "openssl")
-                               "/lib/libcrypto.so"))
-               (("libssl.so")
-                (string-append (assoc-ref inputs "openssl")
-                               "/lib/libssl.so")))
-             #t))
-         (add-after 'unpack 'noninteractive-build
-           ;; This applies upstream commit 4c597d3f7cf9f83a763472aa165a1a4292019f20
-           (lambda _
-             (substitute* "setup.py"
-               (("except NameError")
-                "except EOFError, NameError"))
-             #t))
-         ;; XXX: python setup.py does not build and install bitmsghash,
-         ;; without it PyBitmessage tries to compile it at first run
-         ;; in the store, which due to obvious reasons fails. Do it
-         ;; and place it in /lib.
-         (add-after 'unpack 'build-and-install-bitmsghash
-           (lambda* (#:key outputs #:allow-other-keys)
-             (with-directory-excursion "src/bitmsghash"
-               (system* "make")
-               (install-file "bitmsghash.so"
-                             (string-append (assoc-ref outputs "out") "/lib")))
-             #t)))))
-    (license license:expat)
-    (description
-     "Distributed and trustless peer-to-peer communications protocol
-for sending encrypted messages to one person or many subscribers.")
-    (synopsis "Distributed peer-to-peer communication")
-    (home-page "https://bitmessage.org/")))
-
 (define-public ytalk
   (package
     (name "ytalk")