summary refs log tree commit diff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-20 22:32:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-20 22:44:06 +0100
commit341ed63f47766570229567dd45c04dc0d6db1e94 (patch)
treecc3341a9dd22f75aa339241e92f72f3cd330c29b /gnu/packages/messaging.scm
parent4fd95d917026a4d245604ee53b6547317c4bf2b9 (diff)
downloadguix-341ed63f47766570229567dd45c04dc0d6db1e94.tar.gz
gnu: ngircd: Use ‘modify-phases’ syntax.
* gnu/packages/messaging.scm (ngircd)[arguments]: Use ‘modify-phases’.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index adc7b01383..535a1d3c62 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -235,28 +235,27 @@ dictionaries.  HexChat can be extended with multiple addons.")
                '("--with-pam")
                '()))
        #:phases
-       ;; Necessary for the test suite.
-       (alist-cons-after
-        'configure 'post-configure
-        (lambda _
-          (substitute* "src/ngircd/Makefile"
-            (("/bin/sh") (which "sh")))
-          ;; The default getpid.sh does a sloppy grep over 'ps -ax' output,
-          ;; which fails arbitrarily.
-          (with-output-to-file "src/testsuite/getpid.sh"
-            (lambda ()
-              (display
-               (string-append
-                "#!" (which "sh") "\n"
-                "ps -C \"$1\" -o pid=\n"))))
-          ;; Our variant of getpid.sh does not work for interpreter names if a
-          ;; shebang script is run directly as "./foo", so patch cases where
-          ;; the test suite relies on this.
-          (substitute* "src/testsuite/start-server.sh"
-            ;; It runs 'getpid.sh sh' to test if it works at all.  Run it on
-            ;; 'make' instead.
-            (("getpid.sh sh") "getpid.sh make")))
-        %standard-phases)))
+       (modify-phases %standard-phases
+         ;; Necessary for the test suite.
+         (add-after 'configure 'post-configure
+           (lambda _
+             (substitute* "src/ngircd/Makefile"
+               (("/bin/sh") (which "sh")))
+             ;; The default getpid.sh does a sloppy grep over 'ps -ax' output,
+             ;; which fails arbitrarily.
+             (with-output-to-file "src/testsuite/getpid.sh"
+               (lambda ()
+                 (display
+                  (string-append
+                   "#!" (which "sh") "\n"
+                   "ps -C \"$1\" -o pid=\n"))))
+             ;; Our variant of getpid.sh does not match interpreter names
+             ;; when the script's shebang is invoked directly as "./foo".
+             ;; Patch cases where the test suite relies on this.
+             (substitute* "src/testsuite/start-server.sh"
+               ;; It runs 'getpid.sh sh' to test if it works at all.  Run it on
+               ;; 'make' instead.
+               (("getpid.sh sh") "getpid.sh make")))))))
     (home-page "http://ngircd.barton.de/")
     (synopsis "Lightweight Internet Relay Chat server for small networks")
     (description