summary refs log tree commit diff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-09-22 21:00:43 +0200
committerJohn Darrington <jmd@gnu.org>2016-09-22 21:07:33 +0200
commitc788c5feb154e5b4d909d34f259a5f1ea6e7c572 (patch)
tree7a6b3d889f075192b1e845c505d05b731c0eecb0 /gnu/packages/messaging.scm
parent163d93a6bd231596959e2e157b60eb964db85d04 (diff)
downloadguix-c788c5feb154e5b4d909d34f259a5f1ea6e7c572.tar.gz
gnu: Add ytalk
* gnu/packages/messaging.scm (ytalk): New variable.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2b0ffee972..55247bef58 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -759,4 +759,29 @@ for sending encrypted messages to one person or many subscribers.")
     (synopsis "Distributed peer-to-peer communication")
     (home-page "https://bitmessage.org/")))
 
+
+(define-public ytalk
+  (package
+    (name "ytalk")
+    (version "3.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "ftp://ftp.ourproject.org/pub/ytalk/ytalk-"
+                           version  ".tar.gz"))
+       (sha256
+        (base32
+         "1d3jhnj8rgzxyxjwfa22vh45qwzjvxw1qh8fz6b7nfkj3zvk9jvf"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (home-page "http://ytalk.ourproject.org")
+    (synopsis "Multi-user chat program")
+    (description "Ytalk is a replacement for the BSD talk program.  Its main
+advantage is the ability to communicate with any arbitrary number of users at
+once.  It supports both talk protocols (\"talk\" and \"ntalk\") and can communicate
+with several different talk daemons at the same time.")
+    (license license:gpl2+)))
+
+
 ;;; messaging.scm ends here