summary refs log tree commit diff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-07-07 01:19:17 -0400
committerMark H Weaver <mhw@netris.org>2014-07-07 17:17:18 -0400
commitfa40e4d4ec92222fa68cb9694812a310344cc4f0 (patch)
tree25da6d4853211e7c4438dd79829a016a3afa4795 /gnu/packages/messaging.scm
parent59c51be2900b896d87b2393faecfef732d015e34 (diff)
downloadguix-fa40e4d4ec92222fa68cb9694812a310344cc4f0.tar.gz
gnu: bitlbee: Upgrade to 3.2.2.
* gnu/packages/messaging.scm (bitlbee): Upgrade to 3.2.2.  Remove patches.
  Use 'libotr' instead of 'libotr-3'.
* gnu/packages/patches/bitlbee-fix-tests.patch: Remove file.
* gnu/packages/patches/bitlbee-memset-fix.patch: Remove file.
* gnu-system.am (dist_patch_DATA): Remove patches.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c1a755ef84..7e2056c347 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -77,20 +77,18 @@ providing:
 (define-public bitlbee
   (package
     (name "bitlbee")
-    (version "3.2.1")
+    (version "3.2.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://get.bitlbee.org/src/bitlbee-"
                                   version ".tar.gz"))
               (sha256
-               (base32 "0n8g5452i5qap43zxb83gxp01d48psf6rr3k1q7z6a3dgpfi3x00"))
-              (patches (list (search-patch "bitlbee-memset-fix.patch")
-                             (search-patch "bitlbee-fix-tests.patch")))))
+               (base32 "13jmcxxgli82wb2n4hs091159xk8rgh7nb02f478lgpjh6996f5s"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("check" ,check)))
     (inputs `(("glib" ,glib)
-              ("libotr" ,libotr-3)
+              ("libotr" ,libotr)
               ("gnutls" ,gnutls)
               ("zlib" ,zlib)  ; Needed to satisfy "pkg-config --exists gnutls"
               ("python" ,python-2)