summary refs log tree commit diff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 22:17:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 22:47:19 -0400
commit7816a81a3db623d429749832996583d394e7bd84 (patch)
treeb380c4d2a23a4da886735a51fe7147bf77a02329 /gnu/packages/monitoring.scm
parentc8bd0da5e901e345b1c5467fd2713724778758d6 (diff)
downloadguix-7816a81a3db623d429749832996583d394e7bd84.tar.gz
gnu: python-carbon: Update to 1.1.8 and rename from python2-carbon.
* gnu/packages/monitoring.scm (python2-carbon): Rename to...
(python-carbon): ... this.  Update to 1.1.8.
[arguments]{python}: Remove argument.
[propagated-inputs]{python2-configparser}: Remove input.
{python-urllib3, python-cachetools}: Add inputs.
{python2-whisper, python2-txamqp}: Upgrade to their Python 3 variants.
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 46dea5eeb8..ad01215f7e 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -380,29 +380,29 @@ historical data.")
 (define-public python2-whisper
   (package-with-python2 python-whisper))
 
-(define-public python2-carbon
+(define-public python-carbon
   (package
-    (name "python2-carbon")
-    (version "1.0.2")
+    (name "python-carbon")
+    (version "1.1.8")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "carbon" version))
        (sha256
         (base32
-         "142smpmgbnjinvfb6s4ijazish4vfgzyd8zcmdkh55y051fkixkn"))))
+         "1wb91fipk1niciffq5xwqbh8g7rl7ghdam4m97cjbig12i5qr4cm"))))
     (build-system python-build-system)
     (arguments
-     `(#:python ,python-2   ; only supports Python 2
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          ;; Don't install to /opt
          (add-after 'unpack 'do-not-install-to-/opt
            (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
     (propagated-inputs
-     `(("python2-whisper" ,python2-whisper)
-       ("python2-configparser" ,python2-configparser)
-       ("python2-txamqp" ,python2-txamqp)))
+     `(("python-cachetools" ,python-cachetools)
+       ("python-txamqp" ,python-txamqp)
+       ("python-urllib3" ,python-urllib3)
+       ("python-whisper" ,python-whisper)))
     (home-page "http://graphiteapp.org/")
     (synopsis "Backend data caching and persistence daemon for Graphite")
     (description "Carbon is a backend data caching and persistence daemon for
@@ -485,9 +485,6 @@ Metrics can be exposed through a standalone web server, or through Twisted,
 WSGI and the node exporter textfile collector.")
     (license license:asl2.0)))
 
-(define-public python2-prometheus-client
-  (package-with-python2 python-prometheus-client))
-
 (define-public go-github-com-prometheus-node-exporter
   (package
     (name "go-github-com-prometheus-node-exporter")