summary refs log tree commit diff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-11 12:01:13 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-11 18:14:06 +0200
commit83168079ac176563ed2b448bb1b2fd0e5d4a5dc3 (patch)
treecba9f5a66e3a4e59845d03c0aba44ec8bd7bdfd4 /gnu/packages/mp3.scm
parent246be103155c362df558a3c36c905c69f8215ae7 (diff)
downloadguix-83168079ac176563ed2b448bb1b2fd0e5d4a5dc3.tar.gz
gnu: mpc123: Allow compilation with GCC 10.
* gnu/packages/mp3.scm (mpc123)[arguments]: In 'configure' phase, call
'setenv'.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index bb9c07bc9d..43398f1e46 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -544,7 +544,9 @@ format.")
            (lambda _
              (substitute* "Makefile"
                (("CC[[:blank:]]*:=.*")
-                "CC := gcc\n"))))
+                "CC := gcc\n"))
+
+             (setenv "CFLAGS" "-fcommon -g")))  ;allow compilation with GCC 10
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))