summary refs log tree commit diff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-12 21:14:12 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-12 21:14:12 +0200
commit4bc5383b3b79b9ee6d42b3a6770d2406035767eb (patch)
tree1b38eb3657c947b803f4fb7f1b1ab95381e73484 /gnu/packages/mpd.scm
parent24418eeb0077250bd79a45defc36d56a1dd8fe96 (diff)
downloadguix-4bc5383b3b79b9ee6d42b3a6770d2406035767eb.tar.gz
gnu: mcg: Cleanup style.
* gnu/packages/mpd.scm (mcg)[source]: Indent as with ‘guix style’.
[arguments]: Convert to list of G-Expressions.
[inputs, native-inputs]: Move below arguments.
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index e1d5b6b2ce..8f58c2128c 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -481,18 +481,28 @@ artists along with albumart.")
   (package
     (name "mcg")
     (version "3.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://gitlab.com/coderkun/mcg")
-         (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "087d3gvx8z1yj7rg9d9h1x02vkw57h4v6xf5pxqyhqyk2435kk17"))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/coderkun/mcg")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "087d3gvx8z1yj7rg9d9h1x02vkw57h4v6xf5pxqyhqyk2435kk17"))))
     (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'wrap-program
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((prog (string-append (assoc-ref outputs "out")
+                                         "/bin/mcg")))
+                (wrap-program prog
+                  `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
+                  `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
     (inputs (list avahi
                   dconf
                   gsettings-desktop-schemas
@@ -505,17 +515,6 @@ artists along with albumart.")
                          gobject-introspection
                          `(,gtk+ "bin")
                          pkg-config))
-    (arguments
-     `(#:glib-or-gtk? #t
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-program
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((prog (string-append (assoc-ref outputs "out")
-                                        "/bin/mcg")))
-               (wrap-program prog
-                 `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
-                 `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
     (synopsis "Covergrid for the MPD")
     (description
      "mcg (CoverGrid) is a client for the Music Player Daemon (MPD), focusing