summary refs log tree commit diff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-23 16:46:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 16:46:06 +0300
commit92ecee94dd411f9b19f686e7b0fd30c662e94567 (patch)
tree92e057aaa24a470217247b0294efc7f197c33d1b /gnu/packages/mpd.scm
parentfffe9a152947801881edb979324183990859f340 (diff)
downloadguix-92ecee94dd411f9b19f686e7b0fd30c662e94567.tar.gz
gnu: sonata: Don't use unstable tarball.
* gnu/packages/mpd.scm (sonata)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 543345d9e0..74c898979e 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -299,14 +299,14 @@ interface for the Music Player Daemon.")
     (name "sonata")
     (version "1.7b1")
     (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://github.com/multani/sonata/archive/v"
-                              version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/multani/sonata")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "07gq2nxqwxs0qyxjbay7k5j25zd386bn7wdr2dl1gk53diwnn7s0"))))
+                "1npbxlrg6k154qybfd250nq2p96kxdsdkj9wwnp93gljnii3g8wh"))))
     (build-system python-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)