summary refs log tree commit diff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-15 08:37:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-10-15 08:38:04 +0200
commitec2a8f602ee0fd2fac2210eeae6d1da091bb47e4 (patch)
tree400eaeb93ba130bb81d2cc3f3ba5a28fccd9c9f6 /gnu/packages/mpd.scm
parentbe0c94a3780c5a11ee50df31ebbfd950bcd00815 (diff)
downloadguix-ec2a8f602ee0fd2fac2210eeae6d1da091bb47e4.tar.gz
gnu: mpd: Update to 0.22.
* gnu/packages/mpd.scm (mpd): Update to 0.22.
[arguments]: Use "enabled" instead of "true".
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index f3e98ccb17..cb063150e2 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2016, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -93,7 +94,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
 (define-public mpd
   (package
     (name "mpd")
-    (version "0.21.26")
+    (version "0.22")
     (source (origin
               (method url-fetch)
               (uri
@@ -102,10 +103,10 @@ interfacing MPD in the C, C++ & Objective C languages.")
                               "/mpd-" version ".tar.xz"))
               (sha256
                (base32
-                "1sjfx9ln2zik5fr5mdjy1w184hgjn89v67i85z09x0m6qwhq5rpr"))))
+                "0xlhwdbnww7gjw474j54j94iwrzbzlqvnv6chlkga6yh4pcl5rvx"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Ddocumentation=true"))) ;the default is 'false'...
+     `(#:configure-flags '("-Ddocumentation=enabled")))
     (inputs `(("ao" ,ao)
               ("alsa-lib" ,alsa-lib)
               ("avahi" ,avahi)