summary refs log tree commit diff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-19 11:31:41 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-19 11:32:48 +0100
commit0d8a8234b5adbed898b37ea7187ab6ab505f83ee (patch)
tree1c512d05bc376a8af9276190b294ab55ca5c1901 /gnu/packages/mpi.scm
parent535a13a2ab1c27955a5b03accab86fab2cf88180 (diff)
downloadguix-0d8a8234b5adbed898b37ea7187ab6ab505f83ee.tar.gz
gnu: hwloc: Adjust references to 'hwloc'.
This is a followup to 8ec7ca22d363b80b173ce87c5f39d5ca9686d248, which
led to a stack overflow (cyclic graph) when attempting to build HWLOC-2.

* gnu/packages/mpi.scm (hwloc-2): Refer to HWLOC-1 instead of HWLOC.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 116fa1ebb0..9f6597c6b3 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -146,9 +146,9 @@ bind processes, and much more.")
                 "0qh8s7pphz0m5cwb7liqmc17xzfs23xhz5wn24r6ikvjyx99fhhr"))))
 
     ;; libnuma is no longer needed.
-    (inputs (alist-delete "numactl" (package-inputs hwloc)))
+    (inputs (alist-delete "numactl" (package-inputs hwloc-1)))
     (arguments
-     (substitute-keyword-arguments (package-arguments hwloc)
+     (substitute-keyword-arguments (package-arguments hwloc-1)
        ((#:phases phases)
         `(modify-phases ,phases
            (replace 'skip-linux-libnuma-test