summary refs log tree commit diff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-08-12 16:43:01 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-19 12:02:35 +0200
commit07adb7e26a447361d474163dd8e1aeb5c36369e5 (patch)
treeed57a0d39a901a805218b720b9715406a6aa35c5 /gnu/packages/mpi.scm
parent2a6ea3895bf554a70c699a1013d75ffa5407bcad (diff)
downloadguix-07adb7e26a447361d474163dd8e1aeb5c36369e5.tar.gz
gnu: Add mpich-ofi.
* gnu/packages/mpi.scm (mpich-ofi): New variable.

Change-Id: I577fa8fc15ffe7df82d737721ca5a2e034c1e43a
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 97471d56e9..f208957f93 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -548,3 +548,28 @@ Gigabit Ethernet, InfiniBand, Myrinet, Quadrics), and proprietary high-end
 computing systems (Blue Gene, Cray).  It enables research in MPI through a
 modular framework for other derived implementations.")
     (license license:bsd-2)))
+
+(define-public mpich-ofi
+  (package/inherit mpich
+    (name "mpich-ofi")
+    (inputs (modify-inputs (package-inputs mpich)
+              (delete ucx)
+              (append libfabric)
+              (append rdma-core)
+              (append psm2)))
+    (arguments
+      (substitute-keyword-arguments (package-arguments mpich)
+        ((#:configure-flags flags)
+         #~(list "--disable-silent-rules" ;let's see what's happening
+                 "--enable-debuginfo"
+                 "--with-device=ch4:ofi"
+
+                 (string-append "--with-hwloc-prefix="
+                                #$(this-package-input "hwloc"))
+
+                 (string-append "--with-libfabric="
+                                #$(this-package-input "libfabric"))))
+        ((#:phases phases
+          '%standard-phases)
+         phases)))
+    (synopsis "Implementation of the Message Passing Interface (MPI) for OmniPath")))