summary refs log tree commit diff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-19 10:28:22 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-19 10:51:53 +0100
commit8ec7ca22d363b80b173ce87c5f39d5ca9686d248 (patch)
treec792afe23239db39a21665bbd579a790459d5b85 /gnu/packages/mpi.scm
parent69f759912db9af8d3161b315d8806720e068679e (diff)
downloadguix-8ec7ca22d363b80b173ce87c5f39d5ca9686d248.tar.gz
gnu: hwloc: Default to 2.x.
* gnu/packages/mpi.scm (hwloc): Rename to...
(hwloc-1): ... this.
(hwloc-2): Adjust 'inherit' clause accordingly.
(hwloc): New variable.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index f51e03a4d7..116fa1ebb0 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -52,7 +52,7 @@
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
 
-(define-public hwloc
+(define-public hwloc-1
   ;; Note: For now we keep 1.x as the default because many packages have yet
   ;; to migrate to 2.0.
   (package
@@ -134,7 +134,7 @@ bind processes, and much more.")
 (define-public hwloc-2
   ;; Note: 2.0 isn't the default yet, see above.
   (package
-    (inherit hwloc)
+    (inherit hwloc-1)
     (version "2.1.0")
     (source (origin
               (method url-fetch)
@@ -163,6 +163,10 @@ bind processes, and much more.")
 (define-deprecated hwloc-2.0 'hwloc-2
   hwloc-2)
 
+(define-public hwloc
+  ;; The latest stable series of hwloc.
+  hwloc-2)
+
 (define-public openmpi
   (package
     (name "openmpi")