summary refs log tree commit diff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-12 16:43:04 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-12 17:20:32 -0500
commit5b527256ee8d280ec6f5d445522beb120005ad84 (patch)
treee617e262c08bde280332ecd66347180848f234c2 /gnu/packages/mpi.scm
parenta37b807769cb5505384acd17d3f042398471f079 (diff)
downloadguix-5b527256ee8d280ec6f5d445522beb120005ad84.tar.gz
gnu: openmpi: Use our hwloc.
* gnu/packages/mpi.scm (hwloc): Propagate numactl.
  (openmpi)[inputs]: Add hwloc.
  [native-inputs]: Add pkg-config.
  [argument]: Add hwloc configure flags.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 071229214b..37b7858469 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -51,16 +51,16 @@
      ;; Enable libpci support, which effectively makes hwloc GPLv2+.
      '(#:configure-flags '("--enable-libpci")))
     (inputs
-     `(("numactl" ,numactl)
-       ("libx11" ,libx11)
+     `(("libx11" ,libx11)
        ("cairo" ,cairo)
        ("ncurses" ,ncurses)
        ("expat" ,expat)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (propagated-inputs
-     ;; 'hwloc.pc' refers to libpci, hence the propagation.
-     `(("pciutils" ,pciutils)))
+     ;; 'hwloc.pc' refers to libpci and libnuma, hence the propagation.
+     `(("numactl" ,numactl)
+       ("pciutils" ,pciutils)))
     (home-page "http://www.open-mpi.org/projects/hwloc/")
     (synopsis "Abstraction of hardware architectures")
     (description
@@ -94,11 +94,14 @@ bind processes, and much more.")
        (base32
         "13z1q69f3qwmmhpglarfjminfy2yw4rfqr9jydjk5507q3mjf50p"))))
     (build-system gnu-build-system)
-    ;; TODO: Use our hwloc instead of the bundled one.
+    (inputs
+     `(("hwloc" ,hwloc)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("gfortran" ,gfortran-4.8)))
     (arguments
-     `(#:configure-flags '("--enable-static"
+     `(#:configure-flags `("--enable-static"
                            "--enable-oshmem"
                            ;; Thread support causes some applications to hang
                            ;; "--enable-event-thread-support"
@@ -106,7 +109,9 @@ bind processes, and much more.")
                            ;; "--enable-orte-progress-threads"
                            ;; "--enable-mpi-thread-multiple"
                            "--enable-mpi-ext=all"
-                           "--with-devel-headers")))
+                           "--with-devel-headers"
+                           ,(string-append "--with-hwloc="
+                                           (assoc-ref %build-inputs "hwloc")))))
     (home-page "http://www.open-mpi.org")
     (synopsis "MPI-2 implementation")
     (description