summary refs log tree commit diff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-02-03 21:05:51 +0100
committerAndreas Enge <andreas@enge.fr>2016-02-03 21:05:51 +0100
commit37d6b0978c6d74d15c6f0df3293b85341c8de562 (patch)
treef52910d1499e153e50e9a009cd19762467e0741e /gnu/packages/mpi.scm
parent35dfcdd753f7600a82c3a766a16e92ce1bcf2272 (diff)
downloadguix-37d6b0978c6d74d15c6f0df3293b85341c8de562.tar.gz
gnu: hwloc: Build without numactl support on armhf.
* gnu/packages/mpi.scm (hwloc)[inputs]: Drop numactl on armhf, where the
  package is not available.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 420291d7f0..abe4fac470 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
+;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -54,8 +55,12 @@
      `(("libx11" ,libx11)
        ("cairo" ,cairo)
        ("ncurses" ,ncurses)
-       ("numactl" ,numactl)
-       ("expat" ,expat)))
+       ("expat" ,expat)
+       ,@(if (not (string-prefix? "armhf"
+                                  (or (%current-target-system)
+                                      (%current-system))))
+             `(("numactl" ,numactl))
+             '())))
     (propagated-inputs
      ;; hwloc.pc lists it in 'Requires.private'.
      `(("libpciaccess" ,libpciaccess)))