summary refs log tree commit diff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-07-31 15:03:46 +0100
committerLudovic Courtès <ludo@gnu.org>2017-08-21 17:04:54 +0200
commitdf981d8b36754c820f41f01758c585bf282065c1 (patch)
tree073cc162df92ed5e8b634716c6c0074e43a49a75 /gnu/packages/mpi.scm
parent0d97d3cbff3d81c8a95b2dc7e037deb04c770779 (diff)
downloadguix-df981d8b36754c820f41f01758c585bf282065c1.tar.gz
gnu: openmpi: Modify configuration to reduce closure.
devel-headers are only for building MCA components, produce a large
closure and aren't normally packaged.  Only the affinity component of
mpi-ext is useful.

* gnu/packages/mpi.scm (openmpi)[arguments]: Don't configure
--with-devel-headers and --enable-mpi-ext=all.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 3337054223..3dd890ed62 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -134,8 +134,7 @@ bind processes, and much more.")
     (arguments
      `(#:configure-flags `("--enable-builtin-atomics"
 
-                           "--enable-mpi-ext=all"
-                           "--with-devel-headers"
+                           "--enable-mpi-ext=affinity" ;cr doesn't work
                            "--enable-memchecker"
                            "--with-sge"
                            ,(string-append "--with-valgrind="