summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-16 08:37:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-16 09:01:56 +0100
commit48b95a193cca73bd2455ba23db73b5f53ab3c4eb (patch)
treeeb017e95f58c9afa2e91f3175efabba05fb07676 /gnu/packages/music.scm
parent45ab28a713b00b52dd022e090b96a3a37fa881b5 (diff)
downloadguix-48b95a193cca73bd2455ba23db73b5f53ab3c4eb.tar.gz
gnu: gx-suppa-tone-bender-lv2: Fetch sources from git.
* gnu/packages/music.scm (gx-suppa-tone-bender-lv2)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index fea8790237..9abce5e711 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2796,14 +2796,14 @@ simulation of a push pull transistor fuzz effect with added high octave."))))
     (name "gx-suppa-tone-bender-lv2")
     (version "0.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/brummer10/"
-                                  "GxSuppaToneBender.lv2/archive/v"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/brummer10/GxSuppaToneBender.lv2.git")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "1j90fns87035sfr6bxs4cvqxbyy3pqjhihx1nis8xajn202nl1hx"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+                "01x6bjmllkmvxfzc5xwdix7w021j26js71awv728cxsmkxgqw0zy"))))
     (home-page "https://github.com/brummer10/GxSuppaToneBender.lv2")
     (synopsis "Simulation of the Vox Suppa Tone Bender pedal")
     (description "This package provides the LV2 plugin