summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-12-03 17:29:58 -0500
committerLeo Famulari <leo@famulari.name>2018-12-03 17:30:30 -0500
commitc05c1910dbd630304e06020d27d4b72bb0502088 (patch)
tree8f8fc3d27aa522120bc05cffaaada15e0a699068 /gnu/packages/music.scm
parent91a4863d9d727754d1743f4c0591c63b950494cf (diff)
downloadguix-c05c1910dbd630304e06020d27d4b72bb0502088.tar.gz
gnu: Beets: Fix compatibility with Python 3.7.
* gnu/packages/patches/beets-python-3.7-fix.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
*  gnu/packages/music.scm (beets)[source]: Use it.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index faf5aab09a..cc6d228006 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2692,6 +2692,7 @@ Songs can be searched by artist, name or even by a part of the song text.")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "beets" version))
+              (patches (search-patches "beets-python-3.7-fix.patch"))
               (sha256
                (base32
                 "0l2vfrknwcsm6bn83m7476qrz45qwgxcb5k0h7kn96kr70irn1v2"))))