summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-10 17:31:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-10 17:31:02 +0200
commit35f909d45c21739ac6f69dae6b98fec8a10b4c5b (patch)
tree538fe38642493f9b50d64da9c488ae62cf2dba8d /gnu/packages/music.scm
parent82bf45c8bd60873eb59aa5e72aac9aeb1402fa51 (diff)
downloadguix-35f909d45c21739ac6f69dae6b98fec8a10b4c5b.tar.gz
gnu: gx-guvnor-lv2: Update to 0.1.
* gnu/packages/music.scm (gx-guvnor-lv2): Update to 0.1.
[source]: Use release tarball.
[arguments]: Remove obsolete Makefile patching.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm69
1 files changed, 32 insertions, 37 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a64511e625..0d45774ef6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2307,44 +2307,39 @@ standard MIDI file with the csvmidi program.")
     (license license:public-domain)))
 
 (define-public gx-guvnor-lv2
-  (let ((commit "9f528a7623a201383e119bb6a2df32b18396a9d5")
-        (revision "1"))
-    (package
-      (name "gx-guvnor-lv2")
-      (version (string-append "0-" revision "." (string-take commit 9)))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/brummer10/GxGuvnor.lv2")
-                      (commit commit)))
-                (sha256
-                 (base32
-                  "10zx84p2vd7i1yqc5ma9p17927265j4g0zfwv9rxladw0nm8y45k"))
-                (file-name (string-append name "-" version "-checkout"))))
-      (build-system gnu-build-system)
-      (arguments
-       `(;; The check target is used only to output a warning.
-         #:tests? #f
-         #:make-flags
-         (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
-         #:phases
-         (modify-phases %standard-phases
-           (replace 'configure
-             (lambda _
-               (substitute* "Makefile"
-                 (("INSTALL_DIR = .*") "INSTALL_DIR=/lib/lv2\n")
-                 ;; Avoid rebuilding everything
-                 (("install : all") "install:"))
-               #t)))))
-      (inputs
-       `(("lv2" ,lv2)))
-      (home-page "https://github.com/brummer10/GxGuvnor.lv2")
-      (synopsis "Overdrive/distortion pedal simulation")
-      (description "This package provides the LV2 plugin \"GxGuvnor\", a
+  (package
+    (name "gx-guvnor-lv2")
+    (version "0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/brummer10/GxGuvnor.lv2/"
+                                  "archive/v" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0rnfvrvs8qmmldyfmx4llyly33zp68448gx40ywdwj42x0mam92p"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(;; The check target is used only to output a warning.
+       #:tests? #f
+       #:make-flags
+       (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (substitute* "Makefile"
+               (("INSTALL_DIR = .*") "INSTALL_DIR=/lib/lv2\n"))
+             #t)))))
+    (inputs
+     `(("lv2" ,lv2)))
+    (home-page "https://github.com/brummer10/GxGuvnor.lv2")
+    (synopsis "Overdrive/distortion pedal simulation")
+    (description "This package provides the LV2 plugin \"GxGuvnor\", a
 simulation of an overdrive or distortion pedal for guitars.")
-      ;; The LICENSE file says GPLv3 but the license headers in the files say
-      ;; GPLv2 or later.
-      (license license:gpl2+))))
+    ;; The LICENSE file says GPLv3 but the license headers in the files say
+    ;; GPLv2 or later.
+    (license license:gpl2+)))
 
 (define-public gx-vbass-preamp-lv2
   (let ((commit "0e599abab10c7669dd444e5d06f671c2fc1b9c6c")