summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-16 08:38:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-16 09:01:56 +0100
commit37519239ac42dd96ac2a7d86559a0e5f49432583 (patch)
treedc3307bb1f26b1832be4d988e45e7a013ccf32fc /gnu/packages/music.scm
parent48b95a193cca73bd2455ba23db73b5f53ab3c4eb (diff)
downloadguix-37519239ac42dd96ac2a7d86559a0e5f49432583.tar.gz
gnu: gx-hyperion-lv2: Fetch sources from git.
* gnu/packages/music.scm (gx-hyperion-lv2)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9abce5e711..6ccfa5bec0 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2835,14 +2835,14 @@ saturation effect."))))
     (name "gx-hyperion-lv2")
     (version "0.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/brummer10/"
-                                  "GxHyperion.lv2/archive/v"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/brummer10/GxHyperion.lv2.git")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "1pd7l33a14kq73wavgqq7csw4n3mwjz9d5rxaj0jgsyxd3llp3wh"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+                "1vx79s6s9if117y2g0ppdja2sv2wcny6xcfl3j1z4cipahnildxf"))))
     (home-page "https://github.com/brummer10/GxHyperion.lv2")
     (synopsis "Simulation of the Hyperion Fuzz pedal")
     (description "This package provides the LV2 plugin \"GxHyperion\", a