summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-12 19:20:18 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-12 19:21:55 +0100
commit33331efc464d117538ca8f1e9628bf8943e2c9f9 (patch)
treea288c571f7de9d2845ee7017b47610be62b90a28 /gnu/packages/music.scm
parentab042de0f7280d50148bf0bd7a0f9577d8956738 (diff)
downloadguix-33331efc464d117538ca8f1e9628bf8943e2c9f9.tar.gz
gnu: denemo: Improve package style.
* gnu/packages/music.scm (denemo)[native-inputs]: Remove labels.
[arguments]: Use G-expressions.  Remove trailing #T from phases.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 53159dfd43..d82e904490 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -628,37 +628,37 @@ many input formats and provides a customisable Vi-style user interface.")
         (base32 "0pdmjij2635jbw2a24ivk1y4w0z58jbmq9vnz3qrfzw4d469grab"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; Tests require to write $HOME.
-             (setenv "HOME" (getcwd))
-             ;; Replace hard-coded diff file name.
-             (substitute* "tests/integration.c"
-               (("/usr/bin/diff")
-                (search-input-file inputs "/bin/diff")))
-             ;; Denemo's documentation says to use this command to run its
-             ;; test suite.
-             (invoke "make" "-C" "tests" "check")))
-         (add-before 'build 'set-lilypond
-           ;; This phase sets the default path for lilypond to its current
-           ;; location in the store.
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((lilypond (search-input-file inputs "/bin/lilypond")))
-               (substitute* "src/core/prefops.c"
-                 (("g_string_new \\(\"lilypond\"\\);")
-                  (string-append "g_string_new (\""
-                                 lilypond
-                                 "\");"))))
-             #t)))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key inputs #:allow-other-keys)
+              ;; Tests require to write $HOME.
+              (setenv "HOME" (getcwd))
+              ;; Replace hard-coded diff file name.
+              (substitute* "tests/integration.c"
+                (("/usr/bin/diff")
+                 (search-input-file inputs "/bin/diff")))
+              ;; Denemo's documentation says to use this command to run its
+              ;; test suite.
+              (invoke "make" "-C" "tests" "check")))
+          (add-before 'build 'set-lilypond
+            ;; This phase sets the default path for lilypond to its current
+            ;; location in the store.
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let* ((lilypond (search-input-file inputs "/bin/lilypond")))
+                (substitute* "src/core/prefops.c"
+                  (("g_string_new \\(\"lilypond\"\\);")
+                   (string-append "g_string_new (\""
+                                  lilypond
+                                  "\");")))))))))
     (native-inputs
-     `(("diffutils" ,diffutils)
-       ("glib:bin" ,glib "bin")         ; for gtester
-       ("gtk-doc" ,gtk-doc)
-       ("intltool" ,intltool)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list diffutils
+           `(,glib "bin")               ; for gtester
+           gtk-doc
+           intltool
+           libtool
+           pkg-config))
     (inputs
      (list alsa-lib
            aubio