summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-07-29 10:39:47 -0500
committerLeo Famulari <leo@famulari.name>2016-07-29 19:19:49 -0400
commit23319ed674ae4218c70749a206b329069dd2197c (patch)
tree6457fbb8b1d9620f15cca366893aa7a45ac8149d /gnu/packages/music.scm
parentd1c9d3bb42a0278be2acc8ad32d3e49ec8cabb07 (diff)
downloadguix-23319ed674ae4218c70749a206b329069dd2197c.tar.gz
gnu: beets: Update to 1.3.19.
* gnu/packages/music.scm (beets): Update to 1.3.19.
[source]: Remove patch to skip failing tests.
* gnu/packages/patches/beets-image-test-failure.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5d73790e51..9bde1d7ac2 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1518,17 +1519,13 @@ websites such as Libre.fm.")
 (define-public beets
   (package
     (name "beets")
-    (version "1.3.18")
+    (version "1.3.19")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                     "https://pypi.python.org/packages/"
-                     "14/6f/c9c79c5339ab3ecced265ca18adbf5bae3d4058bae737b6164d738fb4d2c/"
-                     name "-" version ".tar.gz"))
-              (patches (search-patches "beets-image-test-failure.patch"))
+              (uri (pypi-uri "beets" version))
               (sha256
                (base32
-                "09pgyywa5llbc36y0lrr21ywgsp8m2zx6p8ncf8hxik28knd5kld"))))
+                "1vi1dh3fr554bnm8y9pjy09hblw18v6cl2jppzwlp72afri1w93b"))))
     (build-system python-build-system)
     (arguments
      `(#:python ,python-2 ; only Python 2 is supported