summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-13 10:56:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-23 15:47:35 +0200
commitc2c9e74891ceb46869dce9e0da1143e6dc6c9c78 (patch)
tree05ff8a118787d5e771debb880ff6927d5c87c04e /gnu/packages/music.scm
parent875dc49b0080e7fcaec328c5731f3cdd7d0f47ea (diff)
downloadguix-c2c9e74891ceb46869dce9e0da1143e6dc6c9c78.tar.gz
gnu: Add mod-host.
* gnu/packages/music.scm (mod-host): New variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 67543872bd..42fc262b01 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1601,6 +1601,55 @@ follows a traditional multi-track tape recorder control paradigm.")
 analogue-like user interface.")
     (license license:gpl2+)))
 
+(define-public mod-host
+  ;; The last release was in 2014 but since then more than 140 commits have
+  ;; been made.
+  (let ((commit "72aca771e3a4e3889641b9bab84985586c9bb926")
+        (revision "1"))
+    (package
+      (name "mod-host")
+      (version (string-append "0.10.6-" revision "." (string-take commit 9)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/moddevices/mod-host")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "19szi8cy65jlchbrmbjbma03g6gxj9zyyp4dgw1k06r0cxbx82gq"))
+                (file-name (string-append name "-" version "-checkout"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; no tests included
+         #:make-flags
+         (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+               "CC=gcc")
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (add-after 'unpack 'fix-jack-installation-directory
+             (lambda _
+               ;; Do not attempt to install files to output of "jack" package.
+               (substitute* "Makefile"
+                 (("\\$\\(shell pkg-config --variable=libdir jack\\)")
+                  "lib"))
+               #t)))))
+      (inputs
+       `(("lilv" ,lilv)
+         ("fftw" ,fftw)
+         ("fftwf" ,fftwf)
+         ("lv2" ,lv2)
+         ("jack" ,jack-1)
+         ("readline" ,readline)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)
+         ("python" ,python-2)))
+      (home-page "https://github.com/moddevices/mod-host")
+      (synopsis "LV2 host for Jack controllable via socket or command line")
+      (description "mod-host is an LV2 plugin host for JACK, controllable via
+socket or command line.")
+      (license license:gpl3+))))
+
 (define-public pianobar
   (package
     (name "pianobar")