summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-16 08:38:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-16 09:01:56 +0100
commitd42c66132e50dfcf8a62da7f3a2e266fe22c05b3 (patch)
treeb2c1108a393cf79cd684c74144c37782a403a78e /gnu/packages/music.scm
parent37519239ac42dd96ac2a7d86559a0e5f49432583 (diff)
downloadguix-d42c66132e50dfcf8a62da7f3a2e266fe22c05b3.tar.gz
gnu: gx-voodoo-fuzz-lv2: Fetch sources from git
* gnu/packages/music.scm (gx-voodoo-fuzz-lv2)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6ccfa5bec0..a0e86bc7c5 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2853,14 +2853,14 @@ simulation of the Hyperion Fuzz pedal.")))
     (name "gx-voodoo-fuzz-lv2")
     (version "0.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/brummer10/"
-                                  "GxVoodoFuzz.lv2/archive/v"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/brummer10/GxVoodoFuzz.lv2.git")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0cc8sg7q493bs6pcq4ipqp6czpxv04nh9yvn8kq2x65ni2208n2f"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+                "1v0scphivri1fk4hl20j13f92i48mnx1zsil4hgnadsmm4nsfw43"))))
     (home-page "https://github.com/brummer10/GxVoodoFuzz.lv2")
     (synopsis "Fuzz effect modelled after the Voodoo Lab SuperFuzz")
     (description "This package provides the LV2 plugin \"GxVoodooFuzz\", a