summary refs log tree commit diff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-23 23:21:59 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-23 23:33:09 +0100
commit21c203a53a617962586ef645b22f80814b05fd65 (patch)
tree7536f5bcbec7e749164155e74ee8784afe02a202 /gnu/packages/ncurses.scm
parent9c9da07f4c28192a05b3a88c7d5d1817ea392d79 (diff)
downloadguix-21c203a53a617962586ef645b22f80814b05fd65.tar.gz
packages: Mark the `arguments' field of <package> as thunked.
* guix/packages.scm (<package>): Mark `arguments' as thunked.
  (package-derivation): Adjust accordingly.  Parameterize
  %CURRENT-SYSTEM to SYSTEM, so that arguments can refer to it.

* guix/build-system/gnu.scm (package-with-explicit-inputs): Expect
  `package-arguments' to always return a list, and return a list.
  (package-with-extra-configure-variable): Likewise.
  (static-package): Likewise.
* gnu/packages/base.scm (patch, findutils, gcc-4.7, binutils-boot0,
  gcc-boot0, glibc-final-with-bootstrap-bash, cross-gcc-wrapper,
  static-bash-for-glibc, binutils-final, gcc-final): Change `arguments'
  from a lambda to a list, and use (%current-system) as needed.
  (nix-system->gnu-triplet, boot-triplet): Have the first argument
  default to (%current-system).
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Have `system'
  default to (%current-system).
  (%bootstrap-gcc): Change `arguments' to a list.
* gnu/packages/gawk.scm (gawk): Likewise.
* gnu/packages/m4.scm (m4): Likewise.
* gnu/packages/make-bootstrap.scm (%glibc-for-bootstrap): Likewise, and
  expect `package-arguments' to return a list.
  (%static-inputs, %gcc-static, tarball-package): Likewise.
* gnu/packages/ncurses.scm (ncurses): Likewise.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm48
1 files changed, 22 insertions, 26 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 1be2551a63..52864a6c77 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -83,34 +83,30 @@
                 "0fsn7xis81za62afan0vvm38bvgzg5wfmv1m86flqcj0nj7jjilh"))))
      (build-system gnu-build-system)
      (arguments
-      (case-lambda
-        ((system)
-         `(#:configure-flags
-           `("--with-shared" "--without-debug" "--enable-widec"
+      `(#:configure-flags
+        `("--with-shared" "--without-debug" "--enable-widec"
 
-             ;; By default headers land in an `ncursesw' subdir, which is not
-             ;; what users expect.
-             ,(string-append "--includedir=" (assoc-ref %outputs "out")
-                             "/include")
+          ;; By default headers land in an `ncursesw' subdir, which is not
+          ;; what users expect.
+          ,(string-append "--includedir=" (assoc-ref %outputs "out")
+                          "/include")
 
-             ;; C++ bindings fail to build on
-             ;; `i386-pc-solaris2.11' with GCC 3.4.3:
-             ;; <http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6395191>.
-             ,,@(if (string=? system "i686-solaris")
-                    '("--without-cxx-binding")
-                    '()))
-           #:tests? #f                            ; no "check" target
-           #:phases (alist-cons-after
-                     'install 'post-install ,post-install-phase
-                     (alist-cons-before
-                      'configure 'patch-makefile-SHELL
-                      ,patch-makefile-phase
-                      (alist-replace
-                       'configure
-                       ,configure-phase
-                       %standard-phases)))))
-        ((system cross-system)
-         (arguments cross-system))))
+          ;; C++ bindings fail to build on
+          ;; `i386-pc-solaris2.11' with GCC 3.4.3:
+          ;; <http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6395191>.
+          ,,@(if (string=? (%current-system) "i686-solaris")
+                 '("--without-cxx-binding")
+                 '()))
+        #:tests? #f                               ; no "check" target
+        #:phases (alist-cons-after
+                  'install 'post-install ,post-install-phase
+                  (alist-cons-before
+                   'configure 'patch-makefile-SHELL
+                   ,patch-makefile-phase
+                   (alist-replace
+                    'configure
+                    ,configure-phase
+                    %standard-phases)))))
      (self-native-input? #t)
      (synopsis
       "GNU Ncurses, a free software emulation of curses in SVR4 and more")