summary refs log tree commit diff
path: root/gnu/packages/nettle.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-25 11:20:55 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-25 11:47:57 +0200
commit39ed6749dddc165c98168c49b13e45c8ba7ba707 (patch)
tree6c1242eca7598f435fc2ba7de792e89ef6945c5b /gnu/packages/nettle.scm
parentb4eab6a6a56e1a08e57b2fd1cdd75fe91c29a642 (diff)
downloadguix-39ed6749dddc165c98168c49b13e45c8ba7ba707.tar.gz
gnu: nettle: Add version 3.0.
* gnu/packages/nettle.scm (nettle-3): New variable.
Diffstat (limited to 'gnu/packages/nettle.scm')
-rw-r--r--gnu/packages/nettle.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index 96407837b4..0df8f001bf 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -52,3 +52,16 @@ fit in easily in almost any context.  It can be easily included in
 cryptographic toolkits for object-oriented languages or in applications
 themselves.")
     (license gpl2+)))
+
+(define-public nettle-3
+  ;; This version is not API-compatible with version 2.  In particular GnuTLS
+  ;; cannot use it yet.  So keep it separate.
+  (package (inherit nettle)
+    (version "3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/nettle/nettle-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "04yrpjz33vrj6j0zxc153b00f93i8hs41syr1ryp7sr64fyw0lcn"))))))