summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 03:26:55 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:37 +0200
commitfa6bcae4c48b6838c960b164b80d9f68a754f855 (patch)
treea599574d4d20b3d849b4514937a05e741b54d9da /gnu/packages/networking.scm
parent798a831f3cac790f7025fe90ae2e5e2e63ca4d46 (diff)
downloadguix-fa6bcae4c48b6838c960b164b80d9f68a754f855.tar.gz
gnu: squid: Update to 4.16.
* gnu/packages/networking.scm (squid): Update to 4.16.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 228f303271..45e48e0c1a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1745,14 +1745,14 @@ TCP connection, TLS handshake and so on) in the terminal.")
 (define-public squid
   (package
     (name "squid")
-    (version "4.15")
+    (version "4.16")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "http://www.squid-cache.org/Versions/v4/squid-"
                            version ".tar.xz"))
        (sha256
-        (base32 "09aaz0hi7q4s5jalgl5i5fakmgzv5akf03gnajlah498mgjs94xn"))))
+        (base32 "0qxswdv90lmbxpb47hnqhjv32q0c8j7qkja6wpd0473wfn8yh03y"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -1766,8 +1766,7 @@ TCP connection, TLS handshake and so on) in the terminal.")
              (substitute* "test-suite/testheaders.sh"
                (("/bin/true")
                 (string-append (assoc-ref inputs "coreutils")
-                               "/bin/true")))
-             #t)))))
+                               "/bin/true"))))))))
     (inputs
      `(("perl" ,perl)
        ("openldap" ,openldap)