summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2017-06-18 00:59:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-18 12:42:36 +0200
commit61253c4f9759fa83c20d9e09d58a7e7c6dd06572 (patch)
tree5afde15a520e9ff3c0caef239fc95a46bb969305 /gnu/packages/networking.scm
parent96fd87c96bd6987a967575aaa931c5a7b1c84e21 (diff)
downloadguix-61253c4f9759fa83c20d9e09d58a7e7c6dd06572.tar.gz
gnu: Add fping.
* gnu/packages/networking.scm (fping): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5d1c432da3..d5acac90c5 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2014, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2015, 2016, 2017 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
 ;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -522,6 +522,31 @@ network frames.")
     (license license:gpl2+)
     (home-page "https://www.wireshark.org/")))
 
+(define-public fping
+  (package
+    (name "fping")
+    (version "4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://fping.org/dist/fping-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1kp81wchi79l8z8rrj602fpjrd8bi84y3i7fsaclzlwap5943sv7"))))
+    (build-system gnu-build-system)
+    (home-page "http://fping.org/")
+    (synopsis "Send ICMP ECHO_REQUEST packets to network hosts")
+    (description
+     "fping is a ping like program which uses the Internet Control Message
+Protocol (ICMP) echo request to determine if a target host is responding.
+fping differs from ping in that you can specify any number of targets on the
+command line, or specify a file containing the lists of targets to ping.
+Instead of sending to one target until it times out or replies, fping will
+send out a ping packet and move on to the next target in a round-robin
+fashion.")
+    (license license:expat)))
+
 (define-public httping
   (package
     (name "httping")