summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-12 14:35:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-13 01:20:19 +0200
commit28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9 (patch)
treefe1b9ce5fdda2230610ad9e815da3e2b65cc733d /gnu/packages/networking.scm
parentfaa83a040a3008782091638133e7bfaaae539857 (diff)
downloadguix-28b5ef11595f9dbc6fcc103d3f34e5b0d73334c9.tar.gz
gnu: Rename google-brotli back to brotli.
Sorry for the noise, but good riddance.  Our nonstandard name for this
package has caused confusion since it was added.  For example, the
duplicate python-brotli and python-google-brotli packages added later,
with the latter name making even less sense.

The Python packages will be fixed in the next commit.

* gnu/packages/compression.scm (google-brotli): Redefine as a
deprecated-package, with…
(brotli): …restored to canonical status.
(python-google-brotli)[inherit]: Adjust accordingly.
* gnu/packages/databases.scm (apache-arrow)[inputs]: Adjust accordingly.
* gnu/packages/fontutils.scm (woff2)[inputs]: Likewise.
* gnu/packages/gnome.scm (libsoup)[propagated-inputs]: Likewise.
* gnu/packages/networking (wireshark)[inputs]: Likewise.
* gnu/packages/node.scm (node-lts)[arguments, native-inputs]: Likewise.
* gnu/packages/python-xyz.scm (python-imagecodecs)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a0c526a83b..2829c082d1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1507,7 +1507,7 @@ of the same name.")
      `(("c-ares" ,c-ares)
        ("glib" ,glib)
        ("gnutls" ,gnutls)
-       ("google-brotli" ,google-brotli)
+       ("brotli" ,brotli)
        ("libcap" ,libcap)
        ("libgcrypt" ,libgcrypt)
        ("libnl" ,libnl)