summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:00 +0100
commitdfc32d8d997da74a6e838b450649bd89905ffdc3 (patch)
treec308b5d67e8e943761994d1fc46fb69d5c847bef /gnu/packages/networking.scm
parent811b9b050ecc392e1e15c81089fba0924b0102ad (diff)
downloadguix-dfc32d8d997da74a6e838b450649bd89905ffdc3.tar.gz
gnu: tftp-hpa: Fix build with GCC 10.
Fixes #53424.

* gnu/packages/networking.scm (tftp-hpa)[arguments]: Rewrite as Gexp list.
Add "CFLAGS=-fcommon" to #:configure-flags.

Reported by Ivan Vilata i Balaguer <ivan@selidor.net>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c4e9d59aec..69e27f3113 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2658,7 +2658,10 @@ speedtest.net.")
                (base32
                 "12vidchglhyc20znq5wdsbhi9mqg90jnl7qr9qs8hbvaz4fkdvmg"))))
     (build-system gnu-build-system)
-    (arguments `(#:tests? #f)) ; no test target
+    (arguments
+     (list #:tests? #f                  ; no test target
+           #:configure-flags
+           #~(list "CFLAGS=-fcommon")))   ; XXX fix 5.2 build with GCC 10
     (synopsis "HPA's tftp client")
     (description
      "This is a tftp client derived from OpenBSD tftp with some extra options