summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 16:26:10 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 19:47:28 +0100
commit2fe29c8490ec2fec6c87f68df657d57998cc59c2 (patch)
tree058f9a20fa653630a4aedd17281c49a0a03a77b3 /gnu/packages/networking.scm
parent98580bd93a38b23f0584922f35f611ed7b1d33e8 (diff)
downloadguix-2fe29c8490ec2fec6c87f68df657d57998cc59c2.tar.gz
gnu: sslh: Update to 1.20.
* gnu/packages/networking.scm (sslh): Update to 1.20.
[native-inputs]: Add perl-conf-libconfig. Remove valgrind.
[arguments]: Re-indent.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6c8f946b0c..7d7fce7563 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1226,7 +1226,7 @@ library remains flexible, portable, and easily embeddable.")
 (define-public sslh
   (package
     (name "sslh")
-    (version "1.19c")
+    (version "1.20")
     (source
      (origin
        (method git-fetch)
@@ -1235,16 +1235,16 @@ library remains flexible, portable, and easily embeddable.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "14x3n25n9md0sw8cda9m5bd8r96xpw1vdkapklw4mxgfcz1k2kxq"))))
+        (base32 "18zhkqlwfh6f5dg1a41a4p7p9g94dgb9nwls1ksy9r5yz174i2fx"))))
     (build-system gnu-build-system)
     (native-inputs
      `(;; Test dependencies.
        ("lcov" ,lcov)
        ("perl" ,perl)
+       ("perl-conf-libconfig" ,perl-conf-libconfig)
        ("perl-io-socket-inet6" ,perl-io-socket-inet6)
        ("perl-socket6" ,perl-socket6)
-       ("psmisc" ,psmisc)
-       ("valgrind" ,valgrind)))
+       ("psmisc" ,psmisc)))             ; for ‘killall’
     (inputs
      `(("libcap" ,libcap)
        ("libconfig" ,libconfig)
@@ -1255,24 +1255,24 @@ library remains flexible, portable, and easily embeddable.")
        (modify-phases %standard-phases
          (delete 'configure)            ; no configure script
          (add-before 'check 'fix-tests
-                     (lambda _
-                       (substitute* "./t"
-                         (("\"/tmp") "$ENV{\"TMPDIR\"} . \"")
-                         ;; The Guix build environment lacks ‘ip6-localhost’.
-                         (("ip6-localhost") "localhost"))
-                       #t))
+           (lambda _
+             (substitute* "./t"
+               (("\"/tmp") "$ENV{\"TMPDIR\"} . \"")
+               ;; The Guix build environment lacks ‘ip6-localhost’.
+               (("ip6-localhost") "localhost"))
+             #t))
          ;; Many of these files are mentioned in the man page. Install them.
          (add-after 'install 'install-documentation
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let* ((out (assoc-ref outputs "out"))
-                             (doc (string-append out "/share/doc/sslh")))
-                        (install-file "README.md" doc)
-                        (for-each
-                         (lambda (file)
-                           (install-file file (string-append doc "/examples")))
-                         (append (find-files "." "\\.cfg")
-                                 (find-files "scripts"))))
-                      #t)))
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (string-append out "/share/doc/sslh")))
+               (install-file "README.md" doc)
+               (for-each
+                (lambda (file)
+                  (install-file file (string-append doc "/examples")))
+                (append (find-files "." "\\.cfg")
+                        (find-files "scripts"))))
+             #t)))
        #:make-flags (list "CC=gcc"
                           "USELIBCAP=1"
                           "USELIBWRAP=1"