summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-06-07 12:07:42 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-16 23:57:41 +0200
commit9317cb3e9c6e65af6473818cadaee12f667a1783 (patch)
treecf84b0a53349c22ae61d1a5cda66bba5910ebe5e /gnu/packages/networking.scm
parent925a57c5d04553ff6c514867348e7d3c5c22ca66 (diff)
downloadguix-9317cb3e9c6e65af6473818cadaee12f667a1783.tar.gz
gnu: hcxtools: Use gexps.
* gnu/packages/networking.scm (hcxtools)[arguments]: Link libraries and
use PREFIX instead of INSTALL_DIR.
[phases]: Use gexps.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 07ee9d3ea0..1d092e6b96 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3289,16 +3289,19 @@ Ethernet and TAP interfaces is supported.  Packet capture is also supported.")
         (base32 "0k2qlq9hz5zc21nyc6yrnfqzga7hydn5mm0x3rpl2fhkwl81lxcn"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
-    (inputs
-     (list curl libpcap openssl zlib))
+    (native-inputs (list pkg-config))
+    (inputs (list curl libpcap openssl zlib))
     (arguments
-     `(#:make-flags
-       (list ,(string-append "CC=" (cc-for-target))
-             (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
-       #:tests? #f                      ; no test suite
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     (list #:make-flags
+           #~(list (string-append "CC="
+                                  #$(cc-for-target)) "LDFLAGS+=-lcrypto"
+                   "LDFLAGS+=-lcurl" "LDFLAGS+=-lz"
+                   (string-append "PREFIX="
+                                  #$output))
+           #:tests? #f                            ;no test suite
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))))
     (home-page "https://github.com/ZerBea/hcxtools")
     (synopsis "Capture wlan traffic to hashcat and John the Ripper")
     (description