summary refs log tree commit diff
path: root/gnu/packages/nfs.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-10 22:34:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-10 22:36:33 +0200
commit1a392ee7aed74e345f5263063fdde9a739082af4 (patch)
tree21ed5bdfabd6001f95a2e02568654e8553405869 /gnu/packages/nfs.scm
parentc1ab1590854e4a1af2436c0c60b8dd570b219598 (diff)
downloadguix-1a392ee7aed74e345f5263063fdde9a739082af4.tar.gz
gnu: nfs-utils: Fix building with glibc@2.28.
* gnu/packages/nfs.scm (nfs-utils)[arguments]: Add custom phase to fix
building with glibc@2.28.
Diffstat (limited to 'gnu/packages/nfs.scm')
-rw-r--r--gnu/packages/nfs.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/nfs.scm b/gnu/packages/nfs.scm
index f6bb5b3b71..bdb36d272b 100644
--- a/gnu/packages/nfs.scm
+++ b/gnu/packages/nfs.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -60,6 +61,13 @@
          ,(string-append "--with-krb5=" (assoc-ref %build-inputs "mit-krb5")))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-glibc-compatability
+           (lambda _
+             (substitute* '("utils/blkmapd/device-discovery.c"
+                            "utils/blkmapd/dm-device.c")
+               (("<sys/stat.h>")
+                "<sys/stat.h>\n#include <sys/sysmacros.h>"))
+             #t))
          (add-before 'configure 'adjust-command-file-names
            (lambda _
              ;; Remove assumptions of FHS from start-statd script