summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-13 22:04:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 09:39:58 +0200
commit1c83b1c0f3fcdaee96bc3cfd7227f043f547e123 (patch)
tree28d1eea4e3a16456489adb349746643edf84a09b /gnu/packages/node-xyz.scm
parentf6b8bd6eb7546382070e8c34124addc305e94673 (diff)
downloadguix-1c83b1c0f3fcdaee96bc3cfd7227f043f547e123.tar.gz
gnu: Add node-far.
* gnu/packages/node-xyz.scm (node-far): New variable.
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index b423e3267f..e7135ed781 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -45,6 +45,36 @@
 @code{localStorage} fallbacks.")
     (license license:expat)))
 
+(define-public node-far
+  (package
+    (name "node-far")
+    (version "0.0.7")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/felixge/node-far")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "083rv1rszjn0i91zcpaghlid0kwhk0angmpj4hiflrlyhd6cmjzw"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             ;; We skip the two tests which are supposed to fail.
+             (invoke "bin/node-far" "-v" "test/" "-e" "test.*fail.js"))))))
+    (inputs
+     `(("node-oop" ,node-oop)))
+    (home-page "https://github.com/felixge/node-far")
+    (synopsis "Node.js test runner")
+    (description "This package provides a simple test runner that finds and runs
+multiple node.js files, while providing useful information about output and exit
+codes.")
+    (license license:expat)))
 
 (define-public node-long-stack-traces
   (package