summary refs log tree commit diff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-13 22:04:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 09:39:47 +0200
commit0a2d61a5944c24d18329b3534c06a3b11010b19d (patch)
tree56f399153d5a4c316e5ae398dd477b32e6c77b66 /gnu/packages/node-xyz.scm
parent3b02036ea0c0261895fca8129f8afef297d346e6 (diff)
downloadguix-0a2d61a5944c24d18329b3534c06a3b11010b19d.tar.gz
gnu: Add node-env-variable.
* gnu/packages/node-xyz.scm (node-env-variable): New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Register it.
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
new file mode 100644
index 0000000000..896c0628a6
--- /dev/null
+++ b/gnu/packages/node-xyz.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages node-xyz)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system node))
+
+(define-public node-env-variable
+  (package
+    (name "node-env-variable")
+    (version "0.0.4")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/bigpipe/env-variable")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0nnpxjxfhy4na7fixb7p3ww6ard5xgggfm83b78i333867r4gmsq"))))
+    (build-system node-build-system)
+    (arguments '(#:tests? #f)) ; No tests.
+    (home-page "https://github.com/bigpipe/env-variable")
+    (synopsis "Environment variables for Node with fallbacks")
+    (description "This package provides environment variables with
+@code{process.env}, @code{window.name}, @code{location.hash} and
+@code{localStorage} fallbacks.")
+    (license license:expat)))