summary refs log tree commit diff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-13 01:43:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-13 01:43:47 +0200
commit4c482696a68fc68ddd56fad2d397873089f1d0a3 (patch)
treed7ec02bde9d7992865186f7d34f33b8fec4996ff /gnu/packages/node.scm
parent7555d539245ff3456848c02d61f9e601ee5af463 (diff)
downloadguix-4c482696a68fc68ddd56fad2d397873089f1d0a3.tar.gz
gnu: node: Update to 10.16.0.
* gnu/packages/node.scm (node): Update to 10.16.0.
[arguments]: Enable previously failing tests.  Disable
'sequential/test-performance.js' and 'parallel/test-dns.js'.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index df59a42c74..05da1ba0e1 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -45,14 +45,14 @@
 (define-public node
   (package
     (name "node")
-    (version "10.15.3")
+    (version "10.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.xz"))
               (sha256
                (base32
-                "1mcijznh481s44i59p571a38bfvcxm9f8x2l0l1005aly0kdj8jf"))
+                "0236jlb1hxhzqjlmmlxipcycrndiq92c8434iyy7zshh3n4pzqqq"))
               (modules '((guix build utils)))
               (snippet
                `(begin
@@ -95,7 +95,8 @@
              (substitute* '("lib/child_process.js"
                             "lib/internal/v8_prof_polyfill.js"
                             "test/parallel/test-child-process-spawnsync-shell.js"
-                            "test/parallel/test-stdio-closed.js")
+                            "test/parallel/test-stdio-closed.js"
+                            "test/sequential/test-child-process-emfile.js")
                (("'/bin/sh'")
                 (string-append "'" (which "sh") "'")))
 
@@ -109,18 +110,13 @@
              ;; FIXME: These tests fail in the build container, but they don't
              ;; seem to be indicative of real problems in practice.
              (for-each delete-file
-                       '("test/async-hooks/test-ttywrap.readstream.js"
-                         "test/parallel/test-util-inspect.js"
-                         "test/parallel/test-v8-serdes.js"
-                         "test/parallel/test-dgram-membership.js"
-                         "test/parallel/test-dns-cancel-reverse-lookup.js"
-                         "test/parallel/test-dns-resolveany.js"
-                         "test/parallel/test-cluster-master-error.js"
+                       '("test/parallel/test-cluster-master-error.js"
                          "test/parallel/test-cluster-master-kill.js"
-                         "test/parallel/test-net-listen-after-destroying-stdin.js"
-                         "test/parallel/test-npm-install.js"
-                         "test/sequential/test-child-process-emfile.js"
-                         "test/sequential/test-http-regr-gh-2928.js"))
+                         ;; See also <https://github.com/nodejs/node/issues/25903>.
+                         "test/sequential/test-performance.js"))
+
+             ;; This requires a DNS resolver.
+             (delete-file "test/parallel/test-dns.js")
 
              ;; These tests have an expiry date: they depend on the validity of
              ;; TLS certificates that are bundled with the source.  We want this