summary refs log tree commit diff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-24 22:12:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-24 22:12:13 +0200
commit36747eb0dad504686560afba51742f782f7c3646 (patch)
tree2a35da31146f0a6693fd9cddfc0c514edefe9c99 /gnu/packages/node.scm
parentffaf5cbd361b6589daac1912aa5a43abea86e52b (diff)
parent0b7b8fb0456475374de24b6302a6ce3cc5921ed0 (diff)
downloadguix-36747eb0dad504686560afba51742f782f7c3646.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index cb57415161..69bd928833 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -26,6 +26,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
+  #:use-module (gnu packages adns)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gcc)
@@ -33,27 +34,30 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
-  #:use-module (gnu packages tls))
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages web))
 
 (define-public node
   (package
     (name "node")
-    (version "7.8.0")
+    (version "7.10.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.gz"))
               (sha256
                (base32
-                "1nkngdjbsm81nn3v0w0c2aqx9nb7mwy3z49ynq4wwcrzfr9ap8ka"))
+                "00vdmb0z8b2sd547bkksgy9dfq5gi5xfd9b3f0rc4ngvpzl3z164"))
               ;; https://github.com/nodejs/node/pull/9077
               (patches (search-patches "node-9077.patch"))))
     (build-system gnu-build-system)
     (arguments
-     ;; TODO: Package http_parser and add --shared-http-parser.
+     ;; TODO: Purge the bundled copies from the source.
      '(#:configure-flags '("--shared-openssl"
                            "--shared-zlib"
                            "--shared-libuv"
+                           "--shared-cares"
+                           "--shared-http-parser"
                            "--without-snapshot")
        #:phases
        (modify-phases %standard-phases
@@ -86,7 +90,9 @@
                          "test/parallel/test-cluster-master-error.js"
                          "test/parallel/test-cluster-master-kill.js"
                          "test/parallel/test-npm-install.js"
-                         "test/sequential/test-child-process-emfile.js"))
+                         "test/sequential/test-child-process-emfile.js"
+                         "test/sequential/test-benchmark-child-process.js"
+                         "test/sequential/test-http-regr-gh-2928.js"))
              #t))
          (replace 'configure
            ;; Node's configure script is actually a python script, so we can't
@@ -121,7 +127,9 @@
        ("util-linux" ,util-linux)
        ("which" ,which)))
     (inputs
-     `(("libuv" ,libuv)
+     `(("c-ares" ,c-ares)
+       ("http-parser" ,http-parser)
+       ("libuv" ,libuv)
        ("openssl" ,openssl)
        ("zlib" ,zlib)))
     (synopsis "Evented I/O for V8 JavaScript")