summary refs log tree commit diff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-04-17 14:55:16 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-04-17 14:55:16 +0200
commit3759deaba1413270e623be7b56b7a4b3856fb6e8 (patch)
tree083e0aabd0c940b59969d4cad9723cc77e559b11 /gnu/packages/node.scm
parent9b9cc951bd1937ebfe830d52efbb5f64827992cc (diff)
downloadguix-3759deaba1413270e623be7b56b7a4b3856fb6e8.tar.gz
gnu: node: Update to 7.8.0.
* gnu/packages/node.scm (node): Update to 7.8.0.
[properties]: Add timeout of 1 h.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 2df7816b59..e8ce2e82f8 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -38,14 +38,14 @@
 (define-public node
   (package
     (name "node")
-    (version "6.8.0")
+    (version "7.8.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.gz"))
               (sha256
                (base32
-                "0lj3250hglz4w5ic4svd7wlg2r3qc49hnasvbva1v69l8yvx98m8"))
+                "1nkngdjbsm81nn3v0w0c2aqx9nb7mwy3z49ynq4wwcrzfr9ap8ka"))
               ;; https://github.com/nodejs/node/pull/9077
               (patches (search-patches "node-9077.patch"))))
     (build-system gnu-build-system)
@@ -62,6 +62,7 @@
              ;; Fix hardcoded /bin/sh references.
              (substitute* '("lib/child_process.js"
                             "lib/internal/v8_prof_polyfill.js"
+                            "test/parallel/test-child-process-spawnsync-shell.js"
                             "test/parallel/test-stdio-closed.js")
                (("'/bin/sh'")
                 (string-append "'" (which "sh") "'")))
@@ -130,4 +131,5 @@ event-driven, non-blocking I/O model that makes it lightweight and efficient,
 perfect for data-intensive real-time applications that run across distributed
 devices.")
     (home-page "http://nodejs.org/")
-    (license expat)))
+    (license expat)
+    (properties '((timeout . 216000)))))