summary refs log tree commit diff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/nss.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index b230044b57..af9003e823 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -52,10 +52,10 @@
     (build-system gnu-build-system)
     (inputs
      ;; For 'compile-et.pl' and 'nspr-config'.
-     `(("perl" ,perl)                   ;for 'compile-et.pl'
-       ("bash-minimal" ,bash-minimal))) ;for 'nspr-config'
+     (list perl ;for 'compile-et.pl'
+           bash-minimal)) ;for 'nspr-config'
     (native-inputs
-     `(("perl" ,perl)))
+     (list perl))
     (arguments
      `(;; Prevent the 'native' perl from sneaking into the closure.
        ;; XXX it would be nice to do the same for 'bash-minimal',
@@ -200,13 +200,11 @@ in the Mozilla clients.")
                (copy-recursively (string-append obj "/bin") bin)
                (copy-recursively (string-append obj "/lib") lib)))))))
     (inputs
-     `(("sqlite" ,sqlite)
-       ("zlib" ,zlib)))
+     (list sqlite zlib))
     (propagated-inputs
-     `(("nspr" ,nspr)))                 ;required by nss.pc.
+     (list nspr))                 ;required by nss.pc.
     (native-inputs
-     `(("perl" ,perl)
-       ("libfaketime" ,libfaketime)))   ;for tests
+     (list perl libfaketime))   ;for tests
 
     ;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
     ;; another build is happening concurrently on the same machine.