summary refs log tree commit diff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-16 16:26:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-16 16:27:03 +0100
commitb329c2139b9f0818f27107bec5226cb98cfe1446 (patch)
tree8fb503a1e89b9c8146408d440cde91ebec641e9d /gnu/packages/ntp.scm
parent12e9687eb925eff12200f86c479344261203a464 (diff)
downloadguix-b329c2139b9f0818f27107bec5226cb98cfe1446.tar.gz
gnu: chrony: Update to 4.2.
* gnu/packages/ntp.scm (chrony): Update to 4.2.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index e93e947929..b98f4513a3 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -45,14 +45,14 @@
 (define-public chrony
   (package
     (name "chrony")
-    (version "4.1")
+    (version "4.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download.tuxfamily.org/chrony/"
                            "chrony-" version ".tar.gz"))
        (sha256
-        (base32 "0k0nf5qqzl01106lkmwc32n6a1fxagalpbci38iccyilz79z4xpd"))))
+        (base32 "16nv90h73c99adh2bdrvlws1lhjsqfp6pfpnlprxd3ijbk8rygr7"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((srfi srfi-26)
@@ -69,16 +69,14 @@
            ;; time would result in nonsense file names in man pages.
            (lambda _
              (substitute* "Makefile.in"
-               (("mkdir -p \\$\\(DESTDIR\\)\\$\\(CHRONYVARDIR\\)") ":"))
-             #t))
+               (("mkdir -p \\$\\(DESTDIR\\)\\$\\(CHRONYVARDIR\\)") ":"))))
          (add-after 'install 'install-more-documentation
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (doc (string-append out "/share/doc/" ,name "-" ,version)))
                (for-each (cut install-file <> doc)
                          (list "README" "FAQ"))
-               (copy-recursively "examples" (string-append doc "/examples"))
-               #t))))))
+               (copy-recursively "examples" (string-append doc "/examples"))))))))
     (native-inputs
      (list pkg-config))
     (inputs