summary refs log tree commit diff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-09-11 20:51:22 -0400
committerLeo Famulari <leo@famulari.name>2020-09-13 15:46:02 -0400
commit898fbb60b2354e82e5b7f259b44dbfed112a83aa (patch)
treef0e35ba5ba5ecc8e0e83b4f3f00aec1d68e0eb3c /gnu/packages/ntp.scm
parent1192ae940434808560b3170107e4ce44855816c3 (diff)
downloadguix-898fbb60b2354e82e5b7f259b44dbfed112a83aa.tar.gz
gnu: Fix a crash in NTP and Chrony.
Fixes <https://bugs.gnu.org/43321>.

* gnu/packages/ntp.scm (ntp, chrony)[inputs]: Replace libcap with libcap/next.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 6b725c2b0f..5fa7d55845 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -80,7 +80,7 @@
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("libcap" ,libcap)
+     `(("libcap" ,libcap/next)
        ("libseccomp" ,libseccomp)
        ("nettle" ,nettle)))
     (home-page "https://chrony.tuxfamily.org/")
@@ -143,7 +143,7 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
       ;; to run as non-root (when invoked with '-u'.)
       ,@(if (string-suffix? "-linux"
                             (or (%current-target-system) (%current-system)))
-            `(("libcap" ,libcap))
+            `(("libcap" ,libcap/next))
             '())))
    (arguments
     `(#:phases